Last week, I tweeted about a bug the RIA Services QA team found.  It’s rather obscure and we decided not to fix it.  I thought it was worth mentioning for at least the humor of it.

Here’s what you must be using in order to see this issue:

  • Windows XP Service Pack 3 - Japanese
  • Visual Web Developer 2010 Express - Japanese
  • WCF RIA Services V1.0 SP1 Beta (or RTM, since we won’t be fixing the issue)
  • VB

And here’s what you do:

  1. Create a new Silverlight Business Application project using WCF RIA Services - Using VB
  2. Build the Solution

Expected Result:

  • The solution builds without error

Actual Result:

  • A seemingly random number of build errors; somewhere between 50 and 75 of them.
  • The build errors all point to the .Designer.vb files for ValidationErrorResources.resx and RegistrationDataResources.resx

Workaround:

  1. Open both ValidationErrorResources.resx and RegistrationDataResources.resx and re-save the files; or
  2. Close and re-open the solution; or
  3. Go to one of the errors that shows up in the XML comments in the Designer.vb files and add a space anywhere in the line.

Once the errors are gone, they stay gone.  They only show up when you first create your solution; it’s quite strange.  I have filed this as a bug in Visual Web Developer 2010 Express, but I don’t know what the bug’s fate will be.

Maybe I’m being naive, but I just can’t imagine that there are many people using:

  1. Windows XP SP3 Japanese (English works fine)
  2. Visual Web Developer 2010 Express Japanese (English works fine)
  3. VB (C# works fine)

Maybe there’s one guy?  If so, he is whom I’m apologizing to in the title of this blog post.  If you know him, please send him the link to this page.  And then send him a license for Windows 7 please.

Technorati Tags: